Android – 更新 Android SDK Platform-tools 所引發的問題解決

這個禮拜 Android 官方一口氣釋出了幾個 SDK 的更新出來,其中一個 Android SDK Platform-tools 會引發 Android SDK 跟 Eclipse 平臺的版本不合問題。當將這個套件更新完後,再開啟 Eclipse 會跳出帶有「This Android SKD requires Android Developer Toolkit version no. or above」這段文字的錯誤提示視窗。

This Android SDK requires Android Developer Toolkit version 21.1.0 or above.

簡單來說,就是 Android SDK 要求我們的開發平臺也需要是相同的版本或是更新的版本,才允許讓我們使用。可是這時候我們用得開發環境是 ADT Bundle,在沒有安裝過 Eclipse 的 ADT 時,點擊了這個視窗中的 Check for Updates ,結果會獲得沒有任何更新(No Updates were found.)的提示視窗。

因此,這個時候,我們要從 Help > Install New Software 開啟安裝新套件的視窗。

Add Repository

  • Name: ADT
  • Location: https://dl-ssl.google.com/android/eclipse/ 

稍等一下,可以看到下面這樣的畫面,只要將 Developer Tools 該區域的選項全部勾選即可。

install_adt

等候其安裝完畢,再重新啟動 Eclipse 就可以使用嘍~

其餘相關 Eclipse 安裝 ADT 的內容可以參考絀作:Eclipse – 建構 Android 的開發環境

 

 

 

本部落格採用創用CC 姓名標示-非商業性-禁止改作 3.0 台灣 授權條款授權,如欲轉載請記得註明「莫希爾(Mosil) 手札

 

Loading Facebook Comments ...

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *